thankyou
Donate to the B3 fund!

"even a small donation helps!"
Donate with PayPal!

Author Topic: [FIXED][1.9.0 beta] command !spamins not working  (Read 2692 times)

Offline lOOza

  • Jr. Member
  • **
  • Posts: 30
    • GameXS
[FIXED][1.9.0 beta] command !spamins not working
« on: December 17, 2012, 06:54:15 AM »
when i do:

!spamins <player>

i just get: [pm]Unrecognized command spamins.

i have this in my b3.xml:
<plugin name="spamcontrol" config="@conf/plugin_spamcontrol.xml" />

and yes, i replaced the old plugin_spamcontrol.xml with the new 1
« Last Edit: December 18, 2012, 06:05:05 PM by Courgette »

Offline Courgette

  • Senior Dev.
  • Hero Member
  • *
  • Posts: 4882
    • Github repository
Re: [1.9.0 beta] command !spamins not working
« Reply #1 on: December 17, 2012, 09:42:37 AM »
Hi lOOza

Could you please proceed as follow :
  • restart the bot
  • wait for b3 to load
  • join your game server
  • type : !leveltest
  • type : !spamins
  • post here the b3.log file you obtained

Offline lOOza

  • Jr. Member
  • **
  • Posts: 30
    • GameXS
Re: [1.9.0 beta] command !spamins not working
« Reply #2 on: December 17, 2012, 05:29:58 PM »
ok, did it as you said.

here is the log output:

http://gamexs.de/stuff/b3.log



Offline Courgette

  • Senior Dev.
  • Hero Member
  • *
  • Posts: 4882
    • Github repository
Re: [1.9.0 beta] command !spamins not working
« Reply #3 on: December 18, 2012, 01:19:24 AM »
Thank you lOOza for your findings and precise info. Thanks to you we have a first bug fixed for this beta test campain :)

Could you confirm the fix by replacing your b3/plugins/spamcontrol.py file with this one : http://bit.ly/TsLc9d
Then restart the bot, join your game server and try the !spamins command.
Let us known if it worked as expected.

Please continue to try out the many commands you are used to and report any weird behavior.

Offline lOOza

  • Jr. Member
  • **
  • Posts: 30
    • GameXS
Re: [1.9.0 beta] command !spamins not working
« Reply #4 on: December 18, 2012, 06:30:59 AM »
Okay yes, it works now,

when i do !spamins b3 tells me now that i am to cool to spam  8)

i tested on my laptop without any privileges spammed 10 times "i need a medic" until the plugin muted me. after looking up with !spamins i saw the correct values.

it works also when i do !spamins @<id> 

good work :)

keep on rocking <3


« Last Edit: December 18, 2012, 08:00:25 AM by lOOza »

 


Rate this page +1 at Google Search