thankyou
Donate to the B3 fund!

"even a small donation helps!"
Donate with PayPal!
In our support boards we aim to provide support for the B3 core in its current state. Older releases of B3 are NOT supported. Check our front page for the latest version. You may post feature requests in our General Discussion board. Modifications and Hacks of the core B3 code are NOT supported.
Before you ask for support: [ Read the Support Instructions ] - More info: [ Full Support Disclaimer ]

Author Topic: [testing] daily builds  (Read 2758 times)

Offline Fat Albert

  • Sr. Member
  • ****
  • Posts: 258
Re: [testing] daily builds
« Reply #15 on: June 17, 2015, 02:59:19 PM »
To try out I have taken a different server because our SR8 server was giving a error in the log wich says something about a wrong parser. It is using a modified engine for the no-stamina mod and others so maybe that has something to do with it.

Now with our FFA server:


App log:


Code: [Select]
150617 14:46:20 DEBUG 'checking database schema'
150617 14:46:20 DEBUG 'loading process instances from the storage'
150617 14:46:20 INFO '0 processes available'
150617 14:46:20 DEBUG 'parsing RSS feeds from: http://forum.bigbrotherbot.net/news-2/?type=rss;action=.xml'
150617 14:46:25 DEBUG u'stored new process in the database: @8:C:\\Users\\kutclan\\Desktop\\b3 27964\\conf\\b3.xml'
150617 14:46:28 INFO u'starting B3[FFA] process: C:\\Users\\kutclan\\Desktop\\b3-1.10.0.dev413-20150617-win32\\b3_run.exe --config C:\\Users\\kutclan\\Desktop\\b3 27964\\conf\\b3.xml --console'
150617 14:46:29 DEBUG u'updated process in the database: @8:C:\\Users\\kutclan\\Desktop\\b3 27964\\conf\\b3.xml'
150617 14:49:06 INFO 'shutting down B3[FFA] process'
150617 14:49:07 DEBUG u'removed process from the database: @8:C:\\Users\\kutclan\\Desktop\\b3 27964\\conf\\b3.xml'
150617 14:49:15 DEBUG u'stored new process in the database: @9:C:\\Users\\kutclan\\Desktop\\b3 27964\\conf\\b3.xml'
150617 14:49:17 INFO u'starting B3[FFA] process: C:\\Users\\kutclan\\Desktop\\b3-1.10.0.dev413-20150617-win32\\b3_run.exe --config C:\\Users\\kutclan\\Desktop\\b3 27964\\conf\\b3.xml --console'
150617 14:49:17 DEBUG u'updated process in the database: @9:C:\\Users\\kutclan\\Desktop\\b3 27964\\conf\\b3.xml'



I don't get any b3.log file...

b3.xml:


Code: [Select]
<?xml version="1.0" encoding="UTF-8"?>


<!--Created by BigBrotherBot Config File Generator at http://config.bigbrotherbot.net (23 Jul 2013 - Tue 00:18:50 CEST)-->


<configuration>
  <settings name="b3">
    <set name="bot_name">B3[FFA]</set>
    <set name="bot_prefix">^1[K^7U^4T]</set>
    <set name="time_format">%I:%M%p %Z %m/%d/%y</set>
    <set name="time_zone">GMT</set>
    <set name="log_level">9</set>
    <set name="logfile">@b3/b3_27964.log</set>
    <set name="parser">iourt42</set>
    <set name="database">mysql://kut:[email protected]/b3ffa2</set>
  </settings>
  <settings name="server">
    <set name="rcon_password">*****</set>
    <set name="port">27964</set>
    <set name="public_ip">217.26.96.248</set>
    <set name="rcon_ip">127.0.0.1</set>
    <set name="delay">0.33</set>
    <set name="lines_per_second">50</set>
    <set name="punkbuster">off</set>
    <set name="game_log">C:\Users\kutclan\Desktop/ffa 27964/q3ut4/games.log</set>
  </settings>
  <settings name="autodoc">
    <set name="type">html</set>
    <set name="maxlevel">100</set>
    <set name="destination">C:\Users\kutclan\Desktop\b3 27964/b3_doc.html</set>
  </settings>
  <settings name="update">
    <set name="channel">stable</set>
  </settings>
  <settings name="messages">
    <set name="kicked_by">$clientname^7 was kicked by $adminname^7 $reason</set>
    <set name="kicked">$clientname^7 was kicked $reason</set>
    <set name="banned_by">$clientname^7 was banned by $adminname^7 $reason</set>
    <set name="banned">$clientname^7 was banned $reason</set>
    <set name="temp_banned_by">$clientname^7 was temp banned by $adminname^7 for $banduration^7 $reason</set>
    <set name="temp_banned">$clientname^7 was temp banned for $banduration^7 $reason</set>
    <set name="unbanned_by">$clientname^7 was un-banned by $adminname^7 $reason</set>
    <set name="unbanned">$clientname^7 was un-banned $reason</set>
  </settings>
  <settings name="plugins">
    <set name="external_dir">@b3/extplugins</set>
  </settings>
  <plugins>
    <plugin name="censorurt" config="@b3/extplugins/conf/plugin_censorurt.xml"/>
    <plugin name="admin" config="@conf/plugin_admin.xml"/>
    <plugin name="stats" config="@conf/plugin_stats.xml"/>
    <plugin name="adv" config="@conf/plugin_adv.xml"/>
    <plugin name="status" config="@conf/plugin_status.xml"/>
    <plugin name="welcome" config="@conf/plugin_welcome.xml"/>
    <plugin name="xlrstats" config="@b3/extplugins/conf/xlrstats.xml"/>
    <plugin name="topkiller" config="@b3/extplugins/conf/plugin_topkiller.xml"/>
    <plugin name="spree" config ="@b3/extplugins/conf/plugin_spree.xml"/>
    <plugin name="poweradminurt" config="@conf/plugin_poweradminurt.ini"/>
    <plugin name="forceteam" config ="@b3/extplugins/conf/forceteam.xml"/>
    <plugin name="pingkicker" config ="@b3/extplugins/conf/plugin_pingkicker.xml"/>
    <plugin name="firstkill" config ="@b3/extplugins/conf/firstkill.xml"/>
    <plugin name="knifer" priority="##" config="@b3/extplugins/conf/knifer.xml"/>
    <plugin name="ctime" priority="##" config="@b3/extplugins/conf/plugin_ctime.xml"/>
    <plugin name="afk" config="@b3/extplugins/afk/conf/plugin_afk.ini"/>
    <plugin name="countryfilter" config="@b3/extplugins/conf/countryfilter.xml"/>
    <plugin name="maprate" config="@b3/extplugins/conf/maprate.ini"/>
 </plugins>


</configuration>

[attachment deleted by admin]
« Last Edit: June 17, 2015, 05:02:04 PM by Fenix »

Offline Fenix

  • Dev. Team
  • Hero Member
  • *
  • Posts: 983
    • GitHub
Re: [testing] daily builds
« Reply #16 on: June 17, 2015, 03:27:50 PM »
Can you please check if the log file is being created in C:\Users\<your-username\BigBrotherBot?
Also please post the console screenshort (click on the black icon to open it.

Offline Fat Albert

  • Sr. Member
  • ****
  • Posts: 258
Re: [testing] daily builds
« Reply #17 on: June 17, 2015, 03:40:24 PM »
Yes, it is created in that BigBrotherBot folder in the C: - Users - ... directory that you gave. That log is the only thing in that map.

It's not worth to make a screenshot about the console because it remains black...

Offline Fenix

  • Dev. Team
  • Hero Member
  • *
  • Posts: 983
    • GitHub
Re: [testing] daily builds
« Reply #18 on: June 17, 2015, 03:44:01 PM »
Which is very weird. Can you open a command prompt and start B3 using: b3_run.exe --config /path/to/conf/b3.xml --console?
« Last Edit: June 17, 2015, 03:46:10 PM by Fenix »

Offline Fat Albert

  • Sr. Member
  • ****
  • Posts: 258
Re: [testing] daily builds
« Reply #19 on: June 17, 2015, 03:52:59 PM »
Im not sure what you mean with that path.

i write cmd in Start and have to load to the right directory so if I am on desktop and i have made a shortcut of that new b3.exe what path does it have to be?


By the way, I'm not sure what I did, but I just received a error window while or after starting the b3 via the new window:

[attachment deleted by admin]

Offline Fenix

  • Dev. Team
  • Hero Member
  • *
  • Posts: 983
    • GitHub
Re: [testing] daily builds
« Reply #20 on: June 17, 2015, 03:54:50 PM »
Ok, this is supposed to happen so we are good. Now I have to investigate why B3 does not start on your system and it does on all my systems. 
Which operating system are you running?

Offline Fat Albert

  • Sr. Member
  • ****
  • Posts: 258
Re: [testing] daily builds
« Reply #21 on: June 17, 2015, 03:58:33 PM »
All the servers and b3 are running at a Windows 64-bit

Offline Fenix

  • Dev. Team
  • Hero Member
  • *
  • Posts: 983
    • GitHub
Re: [testing] daily builds
« Reply #22 on: June 17, 2015, 03:59:17 PM »
Which Windows version? Xp, 7, 8, 2000?

Offline Fat Albert

  • Sr. Member
  • ****
  • Posts: 258
Re: [testing] daily builds
« Reply #23 on: June 17, 2015, 04:01:30 PM »
2008 R2 Standard

Rack Airflow Requirements Rack 10000 G2 series Cabinets
« Last Edit: June 17, 2015, 04:13:30 PM by Fat Albert »

Offline Fenix

  • Dev. Team
  • Hero Member
  • *
  • Posts: 983
    • GitHub
Re: [testing] daily builds
« Reply #24 on: June 17, 2015, 04:32:36 PM »
I did test on Windows 8 (do not have time to setup a Windows 2008 vm till the weekend and it works as supposed to. In the screen below you can see the console being initialized correctly even though the log file specified does not exists, and rcon ip/port/password are invalid ones.

[attachment deleted by admin]

Offline Fat Albert

  • Sr. Member
  • ****
  • Posts: 258
Re: [testing] daily builds
« Reply #25 on: June 17, 2015, 04:40:15 PM »
Hmm... I see you have a .ini button in that window. Maybe there is a difference between using configuration files b3.xml and b3.ini?

Offline Fenix

  • Dev. Team
  • Hero Member
  • *
  • Posts: 983
    • GitHub
Re: [testing] daily builds
« Reply #26 on: June 17, 2015, 04:45:29 PM »
Nah, they both works fine here


Inviato dal mio iPhone utilizzando Tapatalk

Offline Fenix

  • Dev. Team
  • Hero Member
  • *
  • Posts: 983
    • GitHub
Re: [testing] daily builds
« Reply #27 on: June 17, 2015, 05:34:43 PM »
I'm compiling a new daily build (last for today) in which I added some more logging to the UI module so we can inspect better what's going on. The build is .dev414 and should be ready in some minutes. Hopefully you could give it a try and post the generated app.log. ;)

Offline Fenix

  • Dev. Team
  • Hero Member
  • *
  • Posts: 983
    • GitHub
Re: [testing] daily builds
« Reply #28 on: June 17, 2015, 07:51:43 PM »
Don't know why the build this pushed on the remote server, but you can download it from here: removed
« Last Edit: June 18, 2015, 10:18:08 AM by Fenix »

Offline Fat Albert

  • Sr. Member
  • ****
  • Posts: 258
Re: [testing] daily builds
« Reply #29 on: June 18, 2015, 01:40:50 AM »
Just started version 415. The link you gave in your latest message doesn't work.

Here the app.log:

150618 01:36:49 DEBUG 'checking database schema'
150618 01:36:49 DEBUG 'loading process instances from the storage'
150618 01:36:50 INFO '1 processes available'
150618 01:36:50 DEBUG u'B3[FFA]: @10:C:\\Users\\kutclan\\Desktop\\b3 27964\\conf\\b3.xml'
150618 01:36:50 DEBUG 'parsing RSS feeds from: http://forum.bigbrotherbot.net/news-2/?type=rss;action=.xml'
150618 01:36:56 DEBUG u'removed process from the database: @10:C:\\Users\\kutclan\\Desktop\\b3 27964\\conf\\b3.xml'
150618 01:37:16 DEBUG u'stored new process in the database: @11:C:\\Users\\kutclan\\Desktop\\b3 27964\\conf\\b3.xml'
150618 01:37:20 INFO u'attempt to start B3[FFA] process: C:\\Users\\kutclan\\Desktop\\b3-1.10.0.dev415-20150617-win32\\b3_run.exe --config C:\\Users\\kutclan\\Desktop\\b3 27964\\conf\\b3.xml --console'
150618 01:37:20 DEBUG u'updated process in the database: @11:C:\\Users\\kutclan\\Desktop\\b3 27964\\conf\\b3.xml'
150618 01:37:20 INFO 'process B3[FFA] started successfully'


No sign of it in-game though...

 


Rate this page +1 at Google Search

anything