thankyou
Donate to the B3 fund!

"even a small donation helps!"
Donate with PayPal!
In our support boards we aim to provide support for the B3 core in its current state. Older releases of B3 are NOT supported. Check our front page for the latest version. You may post feature requests in our General Discussion board. Modifications and Hacks of the core B3 code are NOT supported.
Before you ask for support: [ Read the Support Instructions ] - More info: [ Full Support Disclaimer ]

Author Topic: My problem with B3  (Read 395 times)

Offline jonnyuk

  • Jr. Member
  • **
  • Posts: 24
My problem with B3
« on: December 16, 2016, 04:47:08 PM »
Hello,

I know support has stopped for B3 but I was wondering if anyone is able to identify what is causing my problem.

So I noticed that in my echelon (custom built version) some players weren't showing in it, when I looked in the database at the current_clients table it showed that they had a level of 0 and a b3id of 0.

Upon further inspection I found that B3 had assigned a player with the id of 4294967295 which is the highest possible id number, this prevents any other clients from being inserted into the database, when I delete that database entry, it just gives the next player that connects that ID and so on.

If anybody is able to help I would greatly appreciate it!

Offline 82ndAB.Bravo17

  • Dev. Team
  • Hero Member
  • *
  • Posts: 2627
Re: My problem with B3
« Reply #1 on: December 16, 2016, 06:56:12 PM »
Wow, you have one very popular server!

Your auto_increment value for the clients table has got messed up somehow. I suggest you look at the table and see what has actually happened - if it has suddenly jumped and missed out a whole few billion ids then I would just reset the auto_increment value for the table in phpmyadmin back to something that is just above the lower range of current values and see if that cures it. Make sure you copy the database before doing anything like this.

 


Rate this page +1 at Google Search