thankyou
Donate to the B3 fund!

"even a small donation helps!"
Donate with PayPal!
In our support boards we aim to provide support for the B3 core in its current state. Older releases of B3 are NOT supported. Check our front page for the latest version. You may post feature requests in our General Discussion board. Modifications and Hacks of the core B3 code are NOT supported.
Before you ask for support: [ Read the Support Instructions ] - More info: [ Full Support Disclaimer ]

Author Topic: CoD4 instalation Problem, B3 Starts  (Read 361 times)

Offline malucko

  • Newbie
  • *
  • Posts: 7
CoD4 instalation Problem, B3 Starts
« on: January 14, 2017, 10:31:11 PM »
Hello to all, i followed trough the installation process of  the B3 mod and what happens is when i start B3, it goes trough the instalation process, everything starts, it says in game something about B3 and then what b3.log says to me that b3 has shut down as soon as it started bellow i'm leaving my log file. Please help...

My Log is HERE
http://pastebin.com/1Ahev8jb

Config

Code: [Select]
<?xml version="1.0" encoding="UTF-8"?>
<!--Created by BigBrotherBot Config File Generator at http://config.bigbrotherbot.net (14 Jan 2017 - Sat 21:20:57 CET)-->
<configuration>
  <settings name="b3">
    <set name="bot_name">b3</set>
    <set name="bot_prefix">^0(^2b3^0)^7:</set>
    <set name="time_format">%I:%M%p %Z %m/%d/%y</set>
    <set name="time_zone">CET</set>
    <set name="log_level">9</set>
    <set name="logfile">bot/b3.log</set>
    <set name="parser">cod4</set>
    <set name="database">mysql://root:[email protected]/b3rot</set>
  </settings>
  <settings name="server">
    <set name="rcon_password">asdasdasd</set>
    <set name="port">28965</set>
    <set name="public_ip">46.101.182.***</set>
    <set name="rcon_ip">46.101.182.***</set>
    <set name="delay">0.33</set>
    <set name="lines_per_second">50</set>
    <set name="punkbuster">on</set>
    <set name="game_log">cod4/cod4/games_mp.log</set>
  </settings>
  <settings name="autodoc">
    <set name="type">html</set>
    <set name="maxlevel">100</set>
    <set name="destination">@conf/b3_doc.html</set>
  </settings>
  <settings name="update">
    <set name="channel">stable</set>
  </settings>
  <settings name="messages">
    <set name="kicked_by">$clientname^7 was kicked by $adminname^7 $reason</set>
    <set name="kicked">$clientname^7 was kicked $reason</set>
    <set name="banned_by">$clientname^7 was banned by $adminname^7 $reason</set>
    <set name="banned">$clientname^7 was banned $reason</set>
    <set name="temp_banned_by">$clientname^7 was temp banned by $adminname^7 for $banduration^7 $reason</set>
    <set name="temp_banned">$clientname^7 was temp banned for $banduration^7 $reason</set>
    <set name="unbanned_by">$clientname^7 was un-banned by $adminname^7 $reason</set>
    <set name="unbanned">$clientname^7 was un-banned $reason</set>
  </settings>
  <settings name="plugins">
    <set name="external_dir">@b3/extplugins</set>
  </settings>
  <plugins>
    <plugin name="admin" config="@conf/plugin_admin.xml"/>
  </plugins>
</configuration>

Thank you for your help

Offline 82ndAB.Bravo17

  • Dev. Team
  • Hero Member
  • *
  • Posts: 2522
Re: CoD4 instalation Problem, B3 Starts
« Reply #1 on: January 15, 2017, 03:53:23 AM »
Do you see any message in the console?

Offline malucko

  • Newbie
  • *
  • Posts: 7
Re: CoD4 instalation Problem, B3 Starts
« Reply #2 on: January 15, 2017, 12:15:35 PM »
Code: [Select]
Starting B3      : www.bigbrotherbot.net (b3) v1.10.10 [AngryBiscuit]
Autorestart mode : OFF
Checking update  : no update available
Loading config   : @conf/b3.xml
Loading parser   : cod4
Activating log   : ~/bot/b2.log
Connecting to DB : OK
Using gamelog    : ~/cod4/cod4/mods/rotu-r-alpha/games_mp.log
Testing RCON     : OK
Loading events   : 42 events loaded
Loading plugins  : ....... (7)
Starting plugins : ....... (7)
Startup complete : B3 is running! Let's get to work!

If you run into problems check your B3 log file for more information
Thats what i get in server console

And this is what i get ingame when i start B3
http://i.imgur.com/lczm5Sq.png

And after it i can enter !iamgod since b3 shuts off instantly, shown in the log...

Offline 82ndAB.Bravo17

  • Dev. Team
  • Hero Member
  • *
  • Posts: 2522
Re: CoD4 instalation Problem, B3 Starts
« Reply #3 on: January 15, 2017, 05:57:11 PM »
Could you set log_level to 8 and then post a new log?

Offline malucko

  • Newbie
  • *
  • Posts: 7
Re: CoD4 instalation Problem, B3 Starts
« Reply #4 on: January 15, 2017, 06:42:52 PM »
Here is the new log with "8"
http://pastebin.com/jH4LvU8X

The thing is, this time when is started b3 i left the putty windows running and opened a new one since the last one i have to "Control + C" to go back to the console and after some time what i see from the logs is that plugin status is running but still even when i !iamgod or any other command nothing happens...

Offline 82ndAB.Bravo17

  • Dev. Team
  • Hero Member
  • *
  • Posts: 2522
Re: CoD4 instalation Problem, B3 Starts
« Reply #5 on: January 16, 2017, 12:20:20 AM »
The log doesn't show you or anyone else joining the server and trying to type anything, try joining and typing a few things so you stay connected for longer.

I think you probably have to leave the putty window open to keep B3 running, but someone who knows Linux would have to confirm that.

Offline malucko

  • Newbie
  • *
  • Posts: 7
Re: CoD4 instalation Problem, B3 Starts
« Reply #6 on: January 16, 2017, 01:13:57 AM »
Thats the thing. B3 is not responding whatever is happening on the server, even when we are on, or when we come after the B3 starts, nothing is responding, sometimes when i close the starting console of b3 the server shuts down and sometimes when i don't B3 keeps doing rcon status and does not parse(listen) anything on the server....

Offline malucko

  • Newbie
  • *
  • Posts: 7
Re: CoD4 instalation Problem, B3 Starts
« Reply #7 on: January 16, 2017, 03:18:43 AM »
New thing happened after some time i decided to "Control + C" my B3 and i got an error.

Code: [Select]
Unhandled exception in thread started by <bound method Cron.run of <b3.cron.Cron object at 0xb6153a8c>>
Traceback (most recent call last):
  File "/root/bot/b3/cron.py", line 352, in run
    if abs(self.time() - nexttime) > 120:
  File "/root/bot/b3/cron.py", line 330, in time
    return time.time()
AttributeError: 'NoneType' object has no attribute 'time'

Offline 82ndAB.Bravo17

  • Dev. Team
  • Hero Member
  • *
  • Posts: 2522
Re: CoD4 instalation Problem, B3 Starts
« Reply #8 on: January 16, 2017, 05:52:12 AM »
The server isn't showing any players being on in response to the status request. Without that there is no way that B3 can 'see' players either.

Offline malucko

  • Newbie
  • *
  • Posts: 7
Re: CoD4 instalation Problem, B3 Starts
« Reply #9 on: January 16, 2017, 03:57:29 PM »
Ok but what now, server had players and we were trying commands but nothing, happens, bot gets some svars as map name etc and puta them inside mysql db, but nothing else is responding or hapening. What is also maybe an issue my game is not exporting games_mp.log so maybe that can be the problem?

Offline 82ndAB.Bravo17

  • Dev. Team
  • Hero Member
  • *
  • Posts: 2522
Re: CoD4 instalation Problem, B3 Starts
« Reply #10 on: January 16, 2017, 05:26:44 PM »
Yes, if server is not writing to that games_mp.log then B3 won't see any commands. You need to find out where it is writing the log and get b3 to read that one.

But if your server is not showing any players in the status command then even using the right log will not help, that is the first thing that you need to sort out.

Offline malucko

  • Newbie
  • *
  • Posts: 7
Re: CoD4 instalation Problem, B3 Starts
« Reply #11 on: January 16, 2017, 06:50:14 PM »
The update is that B3 rcon status can see players on the server but still doesn't react to any command... I am totally lost in here :(

Offline 82ndAB.Bravo17

  • Dev. Team
  • Hero Member
  • *
  • Posts: 2522
Re: CoD4 instalation Problem, B3 Starts
« Reply #12 on: January 16, 2017, 09:37:31 PM »
B3 won't react to any commands unless it is reading the correct games_mp.log. You need to find the log that your server is writing and make sure that you are telling b3 to read it.

The server will write the log to the mod folder for the mod that you are running. If you don't seem to be getting a log in that folder try testing using a different mod, or no mod at all (in which case I think that the log is created in the main folder) and see if your server makes a log then.

 


Rate this page +1 at Google Search