thankyou
Donate to the B3 fund!

"even a small donation helps!"
Donate with PayPal!
In our support boards we aim to provide support for the B3 core in its current state. Older releases of B3 are NOT supported. Check our front page for the latest version. You may post feature requests in our General Discussion board. Modifications and Hacks of the core B3 code are NOT supported.
Before you ask for support: [ Read the Support Instructions ] - More info: [ Full Support Disclaimer ]

Author Topic: what version of python i need for b3 1.10.10  (Read 1286 times)

Offline kungfeu

  • Jr. Member
  • **
  • Posts: 22
what version of python i need for b3 1.10.10
« on: January 11, 2017, 04:55:59 AM »
Hello all
what version of python i need for b3 1.10.10  in windows 
2.7 didn't work
give me the link please and everything i need
thank you

Offline 82ndAB.Bravo17

  • Dev. Team
  • Hero Member
  • *
  • Posts: 2628
Re: what version of python i need for b3 1.10.10
« Reply #1 on: January 11, 2017, 06:22:18 AM »
2.7 should work fine, it does for us.

Offline kungfeu

  • Jr. Member
  • **
  • Posts: 22
Re: what version of python i need for b3 1.10.10
« Reply #2 on: January 11, 2017, 06:21:11 PM »
do i need anothers programes to make it work
i have python 2.7  and when i  start b3
it' didn't work

Offline 82ndAB.Bravo17

  • Dev. Team
  • Hero Member
  • *
  • Posts: 2628
Re: what version of python i need for b3 1.10.10
« Reply #3 on: January 11, 2017, 08:26:58 PM »
do i need anothers programes to make it work
i have python 2.7  and when i  start b3
it' didn't work

Some idea of any errors that you are getting might help - console window and/or log

Offline kungfeu

  • Jr. Member
  • **
  • Posts: 22
Re: what version of python i need for b3 1.10.10
« Reply #4 on: January 16, 2017, 08:19:50 PM »
iam using  source virsion

so when i start it i saw only a black screen  and it's gon fast  and there is no logs

sorry fe my bad english

Offline 82ndAB.Bravo17

  • Dev. Team
  • Hero Member
  • *
  • Posts: 2628
Re: what version of python i need for b3 1.10.10
« Reply #5 on: January 16, 2017, 09:38:41 PM »
Start the program in a cmd window rather than by clicking on the program and you should see the errors.

Offline kungfeu

  • Jr. Member
  • **
  • Posts: 22
Re: what version of python i need for b3 1.10.10
« Reply #6 on: January 17, 2017, 03:40:46 AM »
Code: [Select]
D:\aaa\big-brother-bot-1.10.10>b3_run.py
Traceback (most recent call last):
  File "D:\aaa\big-brother-bot-1.10.10\b3_run.py", line 36, in <module>
    import b3.run
  File "D:\aaa\big-brother-bot-1.10.10\b3\__init__.py", line 369, in <module>
    from b3.update import checkUpdate
  File "D:\aaa\big-brother-bot-1.10.10\b3\update.py", line 358, in <module>
    from b3.parser import StubParser
  File "D:\aaa\big-brother-bot-1.10.10\b3\parser.py", line 204, in <module>
    import dateutil.tz
ImportError: No module named dateutil.tz

Offline kungfeu

  • Jr. Member
  • **
  • Posts: 22
Re: what version of python i need for b3 1.10.10
« Reply #7 on: January 17, 2017, 04:01:40 AM »
i need python-dateutil  right ?
but how to install it
« Last Edit: January 17, 2017, 02:41:48 PM by kungfeu »

Offline 82ndAB.Bravo17

  • Dev. Team
  • Hero Member
  • *
  • Posts: 2628
Re: what version of python i need for b3 1.10.10
« Reply #8 on: January 17, 2017, 03:07:11 PM »
You need to run 
Code: [Select]
pip install -r requirements.txt
[/pre]
That will install all the required python packages.

 


Rate this page +1 at Google Search