thankyou
Donate to the B3 fund!

"even a small donation helps!"
Donate with PayPal!
Most of the plugins here are made by B3 users and the authors may not visit frequently. If you need support for plugins or if questions remain unanswered, you will have to contact the author directly. Read the full Support Disclaimer here

NOTE: Do not attach plugins to your forumtopics! Attachements are periodically removed by maintenance tasks. Upload your plugins to our Downloads section instead!

Author Topic: Callvote Plugin  (Read 2075 times)

Offline Fenix

  • Dev. Team
  • Hero Member
  • *
  • Posts: 984
    • GitHub
Callvote Plugin
« on: May 10, 2014, 03:48:06 PM »
Description

A BigBrotherBot plugin which provides advanced features related to the Urban Terror 4.2 callvotes. For more information please refer to the original readme: https://github.com/danielepantaleone/b3-plugin-callvote/

Requirements

  • Urban Terror 4.2 server [g_modversion >= 4.2.015]
  • B3 [version > 1.10dev]

Installation

  • copy the callvote.py file into b3/extplugins
  • copy the plugin_callvote.ini file in b3/extplugins/conf
  • add to the plugins section of your b3.xml config file:

<plugin name="callvote" config="@b3/extplugins/conf/plugin_callvote.ini" />

Download

Last release: https://github.com/danielepantaleone/b3-plugin-callvote/archive/master.zip
« Last Edit: December 18, 2014, 01:39:14 AM by Fenix »

Offline Mingus

  • Jr. Member
  • **
  • Posts: 15
    • IPDB Sudamericana
Re: Callvote Plugin
« Reply #1 on: May 10, 2014, 05:24:26 PM »
Thanks a lot  ;D

Offline obteo

  • Sr. Member
  • ****
  • Posts: 152
    • B2KilL Clan
Re: Callvote Plugin
« Reply #2 on: June 13, 2016, 03:30:55 PM »
Hi Fenix,

I'm having this error:


Code: [Select]
160613 15:16:26 ERROR    'Could not load plugin callvote'
Traceback (most recent call last):
  File "/home/b2k/cod4/bot/b3/parser.py", line 935, in loadPlugins
    plugin_list += _get_plugin_data(plugin_data)
  File "/home/b2k/cod4/bot/b3/parser.py", line 894, in _get_plugin_data
    p_data.name, self.gameName, ', '.join(p_data.clazz.requiresParsers)))
MissingRequirement: 'plugin callvote is not compatible with cod4 parser : supported games are : iourt42'

do you know why? Thanks.

Offline Fenix

  • Dev. Team
  • Hero Member
  • *
  • Posts: 984
    • GitHub
Re: Callvote Plugin
« Reply #3 on: June 13, 2016, 07:52:56 PM »
It is written in the log. The plugin works only with Urban Terror 4.2

 


Rate this page +1 at Google Search

anything