thankyou
Donate to the B3 fund!

"even a small donation helps!"
Donate with PayPal!
Most of the plugins here are made by B3 users and the authors may not visit frequently. If you need support for plugins or if questions remain unanswered, you will have to contact the author directly. Read the full Support Disclaimer here

NOTE: Do not attach plugins to your forumtopics! Attachements are periodically removed by maintenance tasks. Upload your plugins to our Downloads section instead!

Author Topic: Voting Plugin (by danger89)  (Read 37697 times)

Offline obteo

  • Sr. Member
  • ****
  • Posts: 152
    • B2KilL Clan
Re: Voting Plugin (by danger89)
« Reply #105 on: June 13, 2016, 04:52:42 PM »
Hello,

i'm having this issue:


Code: [Select]
160613 16:50:58 BOT      'Starting plugin #17 : voting'
160613 16:50:58 DEBUG    'AdminPlugin: command "voteyes (vy)" registered with cmd_voteyes for level (1, 100)'
160613 16:50:58 DEBUG    'AdminPlugin: command "voteno (vn)" registered with cmd_voteno for level (1, 100)'
160613 16:50:58 ERROR    'Could not start plugin voting'
Traceback (most recent call last):
  File "/home/b2k/cod4/bot/b3/parser.py", line 1105, in startPlugins
    start_plugin(self, plugin_name)
  File "/home/b2k/cod4/bot/b3/parser.py", line 1096, in start_plugin
    p.onStartup()
  File "/home/b2k/cod4/bot/b3/plugin.py", line 559, in onStartup
    self.startup()  # support backwards compatibility
  File "/home/b2k/cod4/bot/b3/extplugins/voting.py", line 109, in startup
    self._adminPlugin.registerCommand(self, 'voteveto', modLevel, self.cmd_veto,  'vveto')
UnboundLocalError: local variable 'modLevel' referenced before assignment

Do u have a clue?

many thanks.

 


Rate this page +1 at Google Search