thankyou
Donate to the B3 fund!

"even a small donation helps!"
Donate with PayPal!

Full documentation and information about XLRstats version 2 can be found at this subsection of our site.

Our upcoming XLRstats version 3 (League Edition) is currently being developed. You can have a glimpse on our main XLRstats website: www.xlrstats.com


Author Topic: Xlrtopstats double message @topstats spam  (Read 1527 times)

Offline IceFalcon

  • Newbie
  • *
  • Posts: 1
Xlrtopstats double message @topstats spam
« on: November 25, 2013, 01:50:40 PM »
Hello B3


I've recently just purchased a B3 bot streaming service with xlrstats. However, even though the xlrstats and the bot work just fine, there is one issue. In the plugin_adv.xml you can set up that the bot will display the top players according to the xlrtopstats at a given rate (in my case 2 minutes).

The problem is that the bot spams these messages multiple times, like 4 times each, so it goes like this:

XLR TOPSTATS
XLR TOPSTATS
XLR TOPSTATS
XLR TOPSTATS

PLAYER 1
PLAYER1

etc.

Also, my given rate is not respected, and the bot spams the xlrtopstats like every 20-30 seconds or so.
When we use a normal command or just xlrtopstats, the stats get displayed correctly and not double, so I don't think there are more than two instances of the bot running at the same time.

Here's an extract from b3.log:
http://pastebin.com/2XEZETts

I've added the plugin_av.xml file as an attachment. If you rather use pastebin, here it is:

http://pastebin.com/wqufHdzf

Any ideas to fix this? Because it's quite a nuisance.


Thanks in advance,
Steve

[attachment deleted by admin]

Offline 82ndAB.Bravo17

  • Dev. Team
  • Hero Member
  • *
  • Posts: 2605
Re: Xlrtopstats double message @topstats spam
« Reply #1 on: November 25, 2013, 03:58:08 PM »
Try this:

Shut the bot down, and see if you still get any B3 spams showing. If you do then somehow there are other bots connecting to the server, and you need to speak with your provider.

If you don't, then restart B3 and wait 10 minutes and see what spams you get, if you still have the issue stop the bot again and post your b3 log and b3 xml, removing passwords first. Then you can start the bot again.

 


Rate this page +1 at Google Search

anything