Donate to the B3 fund!

"even a small donation helps!"
Donate with PayPal!
Echelon v2 is not yet officially released! If you cannot get this dev-version installed, revert to version 1 as available in our download section.

Author Topic: Echelon v2 PHP Strict Standards Error  (Read 2328 times)

Offline dude4him

  • Newbie
  • *
  • Posts: 7
Echelon v2 PHP Strict Standards Error
« on: February 09, 2014, 04:05:40 PM »
Here is the error:

PHP Strict Standards:  Accessing static property DB_B3::$instance as non static in C:\Inetpub\wwwroot\joomla\echelon\classes\mysql-class.php on line 99

There are two forum posts related to it but no fix.

Windows 2003 - IIS6 - Joomla v2.5.

I can login to the Echelon interface even add a server. However, clicking on any other page gets the PHP Strict Standards error.

Joomla configuration.cfg:
public $error_reporting = 'none';

Joomla root folder htaccess
php_value error_reporting = E_ALL & ~E_STRICT
php_value display_errors = Off

MySQL my.ini file:
sql_mode=""

php.ini settings:
error_reporting = E_ALL & ~E_STRICT
display_errors = Off

Anyone have any success getting past this?

Offline Fenix

  • Dev. Team
  • Hero Member
  • *
  • Posts: 984
    • GitHub
Re: Echelon v2 PHP Strict Standards Error
« Reply #1 on: February 09, 2014, 04:34:26 PM »
I would start by checking other configuration files which may change the error reporting bit. Create a new file name whatever.php and place inside this:

Code: [Select]
<?php
    phpinfo();

visit this page using your browser: there is a section where you can see all the configuration files loaded

Offline dude4him

  • Newbie
  • *
  • Posts: 7
Re: Echelon v2 PHP Strict Standards Error
« Reply #2 on: February 09, 2014, 04:41:16 PM »
Thanks. It's only:

Loaded Configuration File    C:\php\php.ini

Offline dude4him

  • Newbie
  • *
  • Posts: 7
Re: Echelon v2 PHP Strict Standards Error
« Reply #3 on: February 09, 2014, 04:54:29 PM »
It appears I have fixed the error.

I added the following line to \echelon\inc\setup.php

error_reporting(E_ALL & ~E_STRICT & ~E_NOTICE);


What it looks like:
<?php
if (!empty($_SERVER['SCRIPT_FILENAME']) && 'setup.php' == basename($_SERVER['SCRIPT_FILENAME']))
        die ('Please do not load this page directly. Thanks!');

require_once 'config.php'; // if config is not loaded load it in
error_reporting(E_ALL & ~E_STRICT & ~E_NOTICE);
$this_page = cleanvar($_SERVER["PHP_SELF"]);
............
« Last Edit: February 09, 2014, 09:49:02 PM by dude4him »

 


Rate this page +1 at Google Search

anything