2
Donate to the B3 fund!

"even a small donation helps!"
Donate with PayPal!
In our support boards we aim to provide support for the B3 core in its current state. Older releases of B3 are NOT supported. Check our front page for the latest version. You may post feature requests in our General Discussion board. Modifications and Hacks of the core B3 code are NOT supported.
Before you ask for support: [ Read the Support Instructions ] - More info: [ Full Support Disclaimer ]

Author Topic: Plugins trouble. Won't actually start plugins  (Read 1179 times)

Offline lee466

  • Jr. Member
  • **
  • Posts: 22
Plugins trouble. Won't actually start plugins
« on: July 13, 2015, 12:04:22 AM »
Hi i have installed a few plugins and started up B3, it never actaully booted up properly though so i removed all of the plugins i added as well as the code..

After i was going to add them one by one and found the geowelcome plugin that welcomes players.

I loaded it into the ext plugins folder as requested and then started up B3, B3 loaded but the plugin did not work..

Reading through the code that goes something like this:
<plugin name="geowelcome" priority="9" config="@b3/extplugins/conf/geowelcome.xml"/>

I noticed that it is "b3/extplugins"

Does that mean that it is trying to search for the folder b3?

On my computer it is under BigBrotherBot, not b3

Is this why they will not load?

Offline Fenix

  • Dev. Team
  • Hero Member
  • *
  • Posts: 999
    • GitHub
Plugins trouble. Won't actually start plugins
« Reply #1 on: July 13, 2015, 01:14:20 AM »
The @b3 token is resolved to the path b3 code is installed. If you are running the win32 standalone this matches the same directory where b3_run.exe is. If you are running b3 from sources then this path ia resolved to the b3 directory. That directive in your b3.xml, however, simply tells b3 where to find the configuration file: the plugin module path is resolved by b3 automatically first looking into b3.plugins then into b3.extplugins.

Whenever something is not working you need to post a b3 log file or we are would not be able to help you.

Inviato dal mio iPhone utilizzando Tapatalk

Offline lee466

  • Jr. Member
  • **
  • Posts: 22
Re: Plugins trouble. Won't actually start plugins
« Reply #2 on: July 13, 2015, 05:13:55 PM »
Yeah doesn't boot up, this is my B3 log.

[attachment deleted by admin]

Offline Fenix

  • Dev. Team
  • Hero Member
  • *
  • Posts: 999
    • GitHub
Re: Plugins trouble. Won't actually start plugins
« Reply #3 on: July 13, 2015, 05:39:29 PM »
Some plugins are failing in being loaded (geowelcome and banlist). I suggest you (once again) to update your B3 to version 1.10.3 beta: in such version when plugins fail in being loaded B3 won't crash (it will just exclude those plugins leaving information in the log file). Also in B3 1.10.3 banlist and geowelcome plugins are bundled, so you don't need to install them as extplugins.

Offline lee466

  • Jr. Member
  • **
  • Posts: 22
Re: Plugins trouble. Won't actually start plugins
« Reply #4 on: July 13, 2015, 09:38:16 PM »
I don't understand because I got the latest download of B3 from the download section so how can i update it?

Unless its a plugin or something it is the latest version

Offline Fenix

  • Dev. Team
  • Hero Member
  • *
  • Posts: 999
    • GitHub
Re: Plugins trouble. Won't actually start plugins
« Reply #5 on: July 13, 2015, 11:37:43 PM »
I recently published v1.10.4 beta which you can get from here: https://github.com/BigBrotherBot/big-brother-bot/releases (pick one of the nt32 versions). 
You can still use your b3.xml and plugin configuration files, so move them inside the "conf" directory (of B3 1.10.4 deta), then start b3_run.exe: a GUI will pop up asking you to load your B3 configuration file (you can simply drag it in the white panel).

 


Rate this page +1 at Google Search