Donate to the B3 fund!

"even a small donation helps!"
Donate with PayPal!

Author Topic: Need help with !login plugin  (Read 2310 times)

Offline Reindeer

  • Newbie
  • *
  • Posts: 8
Need help with !login plugin
« on: December 04, 2013, 03:49:54 PM »
Hey guys,

I'm trying to install the !login plugin, made by b3, but I can't seem to get it to work.
The admins rights have been hacked today by a xuid/guid changing guy, so I really need this plugin to work.
Also tried the password plugin, now I lost my 100 rights.

When I type !setpassword mypasswhere it comes like this;


After that I try it again, it says;


And when I type /!login mypasswordhere it says


What is going wrong?

EDIT: bot doesnt start anymore, what is wrong? Here is my log.
removed :p

Regards,

Reindeer.
« Last Edit: December 04, 2013, 05:57:33 PM by Reindeer »

Offline 82ndAB.Bravo17

  • Dev. Team
  • Hero Member
  • *
  • Posts: 2628
Re: Need help with !login plugin
« Reply #1 on: December 04, 2013, 05:40:24 PM »
It looks like you may have lost a file or two - check that you still have admin.py in your plugins folder and if not copy it back from the install files.

If that doesn't get it working again post your full B3 log and B3 xml, but remove passwords first - you may want to change your mysql password since it looks like it is in the log snippet that you posted.

Offline Reindeer

  • Newbie
  • *
  • Posts: 8
Re: Need help with !login plugin
« Reply #2 on: December 04, 2013, 06:05:04 PM »
Here's my log.
I've removed my passwords now.

Looks like it can't connect to the database. Can you take a look in it?
http://pastehtml.com/view/dosph1cck.txt

If so ill contact my host.

Thanks

Offline Reindeer

  • Newbie
  • *
  • Posts: 8
Re: Need help with !login plugin
« Reply #3 on: December 05, 2013, 06:16:58 PM »
I tried the password plygin after the login plugin, but now i tried to restart the bot, but it quit working.

Here's my b3.xml.

Hopefully you guys can help me out. I have no clue whats wrong

http://pastebin.com/RP1YLqTb

Thanks..

Offline 82ndAB.Bravo17

  • Dev. Team
  • Hero Member
  • *
  • Posts: 2628
Re: Need help with !login plugin
« Reply #4 on: December 05, 2013, 07:03:55 PM »
You need to make sure that you have the correct details for your mysql database and that you have them in the correct place in the line in the xml. eg b3servers could be your username, but it would seem unlikely if you are using a provider.

You should also remove all of the priority= settings from the plugins section of the xml as they are no longer needed, and you have conflicting ones.

 


Rate this page +1 at Google Search